Excel podstawowy

Lekcja 5 – Konstruowanie formuł (wzorów)

1. Konstruowanie formuł (wzorów)

 

1.1. Podstawowe informacje o formułach

 

Formuła to specjalny zapis wprowadzany do komórek, który przeprowadza określony typ obliczeń, a następnie zwraca ich wynik. Formuły mogą wykorzystywać różne operatory i funkcje do wykonywania operacji na wartościach i tekście. Wartości i tekst mogą znajdować się w innych komórkach, co nadaje arkuszowi bardziej dynamiczny charakter. Na przykład zmienianie danych w arkuszu i obserwowanie wyników obliczeń formuł umożliwia analizę różnych scenariuszy tego samego zdarzenia.

W formule mogą się znajdować następujące elementy:

  • operatory matematyczne, takie jak + (dodawanie) czy *
  • (mnożenie);
  • odwołania do komórek (również do nazw komórek i obszarów);
  • wartości i tekst;
  • funkcje (takie jak SUMA czy ŚREDNIA).

Gdy wprowadzimy formułę, w zawierającej ją komórce jest widoczny wynik jej obliczeń. Samą formułę można obejrzeć na pasku formuły, gdy zaznaczona jest komórka, która ją zawiera.

 

Oto kilka przykładów formuł:

Formuła Działanie formuły
=22*0,05 Mnoży 22 przez 0,05. Formuła ta wykorzystuje tylko wartości i zawsze zwraca ten sam wynik.
=A1+A2 Dodaje wartości komórek A1 i A2.
=Wynagrodzenie – Koszty Oblicza różnicę w wartości komórek nazwanych Wynagrodzenie i Koszty.
=SUMA(A1:A12) Sumuje wartości komórek znajdujących się w obszarze A1:A12.
=A1=B23 Porównuje komórkę A1 z komórką B23. Jeżeli ich wartości są takie same, formuła zwraca wartość logiczną PRAWDA, w przeciwnym razie zwraca wartość FAŁSZ.

 

Formuły zawsze rozpoczynają się znakiem równości (=). W ten sposób Excel odróżnia je od tekstu.

 

1.2. Operatory używane w formułach

 

Operator Działanie
+ dodawanie
odejmowanie
* mnożenie
/ dzielenie
^ potęgowanie
& konkatenacja
= porównanie logiczne (równy)
> porównanie logiczne (większy niż)
< porównanie logiczne (mniejszy niż)
>= porównanie logiczne (większy lub równy)
<= porównanie logiczne (mniejszy lub równy)
<> porównanie logiczne (różny od)

 

1.3. Narzędzie Autosumowanie

 

Wiele zestawień i raportów zawiera dużą liczbę danych w tym najczęściej liczbowych. Najczęściej prosta analiza tych danych zawiera sumą, średnią, liczebność danych, wartość maksymalną
i minimalną. Narzędziem, które wylicza te wyniki automatycznie jest Autosumowanie.

Posługiwanie się Autosumowaniem jest bardzo proste, wystarczy zaznaczyć analizowane dane i wybrać funkcję z zestawu Autosumowania.

 

Funkcje użyte w powyższym przykładzie są następujące:

Nazwa funkcji Składnia
Suma =SUMA(M2:M7)
Średnia =ŚREDNIA(M2:M7)
Wartość maksymalna =MAX(M2:M7)
Wartość minimalna =MIN(M2:M7)
Zliczanie =ILE.LICZB(M2:M7)